<!DOCTYPE html>
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.retouw.nl/xmlrpc.php" />
<title>ControlUp loves Horizon Session Recording! &#8211; Retouw.nl</title>
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Retouw.nl &raquo; Feed" href="https://www.retouw.nl/feed/" />
<link rel="alternate" type="application/rss+xml" title="Retouw.nl &raquo; Comments Feed" href="https://www.retouw.nl/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Retouw.nl &raquo; ControlUp loves Horizon Session Recording! Comments Feed" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.retouw.nl\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='responsive-lightbox-prettyphoto-css'  href='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='enlighterjs-css'  href='https://www.retouw.nl/wp-content/plugins/enlighter/cache/enlighterjs.min.css?ver=phFDMi0UVifQrxR' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='parabola-fonts-css'  href='https://www.retouw.nl/wp-content/themes/parabola/fonts/fontfaces.css?ver=2.3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='parabola-style-css'  href='https://www.retouw.nl/wp-content/themes/parabola/style.css?ver=2.3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.1/css/jetpack.css' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.2.3' id='responsive-lightbox-prettyphoto-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.5.3' id='responsive-lightbox-infinite-scroll-js'></script>
<script type='text/javascript' id='responsive-lightbox-js-extra'>
/* <![CDATA[ */
var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"0","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.75","showTitle":"1","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"pp_default","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.retouw.nl\/wp-admin\/admin-ajax.php","nonce":"11e6461caf"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.3' id='responsive-lightbox-js'></script>
<script type='text/javascript' id='parabola-frontend-js-extra'>
/* <![CDATA[ */
var parabola_settings = {"masonry":"0","magazine":"0","mobile":"1","fitvids":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/themes/parabola/js/frontend.js?ver=2.3.2.2' id='parabola-frontend-js'></script>
<link rel="https://api.w.org/" href="https://www.retouw.nl/wp-json/" /><link rel="alternate" type="application/json" href="https://www.retouw.nl/wp-json/wp/v2/posts/2636" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.retouw.nl/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.retouw.nl/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The VMware Labs flings monthly for October 2020' href='https://www.retouw.nl/2020/11/01/the-vmware-labs-flings-monthly-for-october-2020/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/" />
<link rel='shortlink' href='https://wp.me/p7yl7A-Gw' />
<link rel="alternate" type="application/json+oembed" href="https://www.retouw.nl/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.retouw.nl%2F2020%2F11%2F11%2Fcontrolup-loves-horizon-session-recording%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.retouw.nl/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.retouw.nl%2F2020%2F11%2F11%2Fcontrolup-loves-horizon-session-recording%2F&#038;format=xml" />
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="ControlUp loves Horizon Session Recording!" />
<meta property="og:url" content="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/" />
<meta property="og:description" content="Ok maybe it&#8217;s more me than ControlUp but the usual audience on this blogs knows that I work for ControlUp and that I love the VMware flings. Recently we received the question from several Sou…" />
<meta property="article:published_time" content="2020-11-11T06:15:07+00:00" />
<meta property="article:modified_time" content="2020-11-11T10:34:24+00:00" />
<meta property="og:site_name" content="Retouw.nl" />
<meta property="og:image" content="https://www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143-300x218.png" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="218" />
<meta name="twitter:creator" content="@Magneet_nl" />
<meta name="twitter:site" content="@Magneet_NL" />
<meta name="twitter:text:title" content="ControlUp loves Horizon Session Recording!" />
<meta name="twitter:image" content="https://www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137-300x185.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<style type="text/css">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</style> 
<style type="text/css">/* Parabola Custom CSS */</style>
<script type="text/javascript">var cryout_global_content_width = 930;</script><!--[if lt IE 9]>
<script>
document.createElement('header');
document.createElement('nav');
document.createElement('section');
document.createElement('article');
document.createElement('aside');
document.createElement('footer');
</script>
<![endif]-->
<style id="kirki-inline-styles"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-2636 single-format-standard parabola-image-four caption-light meta-light parabola_triagles parabola-menu-left">

<div id="toTop"> </div>
<div id="wrapper" class="hfeed">

<div class="socials" id="srights">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div>
<div id="header-full">

<header id="header">


		<div id="masthead">

			<div id="branding" role="banner" >

				<div id="header-container">
<div><div id="site-title"><span> <a href="https://www.retouw.nl/" title="Retouw.nl" rel="home">Retouw.nl</a> </span></div><div id="site-description" >Speaking the virtual language</div></div><div class="socials" id="sheader">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div></div>								<div style="clear:both;"></div>

			</div><!-- #branding -->
			<a id="nav-toggle"><span>&nbsp;</span></a>
			<nav id="access" role="navigation">

					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11"><a href="https://www.retouw.nl"><span>Home</span></a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-13"><a href="https://www.retouw.nl/about/"><span>About</span></a>
<ul class="sub-menu">
	<li id="menu-item-1083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1083"><a href="https://www.retouw.nl/public-speaking/"><span>Public speaking</span></a></li>
</ul>
</li>
<li id="menu-item-1813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1813"><a href="https://www.retouw.nl/horizon-api-basics/"><span>Horizon API Basics</span></a>
<ul class="sub-menu">
	<li id="menu-item-1816" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1816"><a href="https://www.retouw.nl/2018/10/08/horizon-view-apis-back-to-basics-part-1-connecting/"><span>Horizon View Api&#8217;s: back to basics part 1: Connecting</span></a></li>
	<li id="menu-item-1815" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1815"><a href="https://www.retouw.nl/2018/10/19/horizon-view-apis-back-to-basics-part-2-queries/"><span>Horizon View Api’s: back to basics part 2: Queries</span></a></li>
	<li id="menu-item-1814" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1814"><a href="https://www.retouw.nl/2018/11/06/horizon-view-apis-back-to-basics-part-3-methods/"><span>Horizon View Api’s: back to basics part 3: Methods</span></a></li>
	<li id="menu-item-1817" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1817"><a href="https://www.retouw.nl/2018/08/11/new-view-api-query-services-in-powercli-10-1-1-pulling-event-information-without-the-sql-password/"><span>New View API query services in PowerCLI 10.1.1: pulling event information without the sql password.</span></a></li>
</ul>
</li>
<li id="menu-item-492" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-492"><a href="https://www.retouw.nl/things-i-am-always-looking-for/"><span>Things I am always looking for</span></a>
<ul class="sub-menu">
	<li id="menu-item-493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493"><a href="https://www.retouw.nl/things-i-am-always-looking-for/install-net-framework-3-5/"><span>Install .net Framework 3.5</span></a></li>
	<li id="menu-item-497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-497"><a href="https://www.retouw.nl/things-i-am-always-looking-for/initialize-horizon-view-powercli-api/"><span>Initialize Horizon view PowerCLI &#038; API</span></a></li>
	<li id="menu-item-500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-500"><a href="https://www.retouw.nl/things-i-am-always-looking-for/create-an-array/"><span>Create an array</span></a></li>
	<li id="menu-item-680" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-680"><a href="https://www.retouw.nl/things-i-am-always-looking-for/links/"><span>Links</span></a></li>
	<li id="menu-item-763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-763"><a href="https://www.retouw.nl/things-i-am-always-looking-for/vdi-windows-versions/"><span>VDI &#038; Windows versions</span></a></li>
</ul>
</li>
<li id="menu-item-549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-549"><a href="https://www.retouw.nl/certifications/"><span>Certifications</span></a></li>
</ul></div>
			</nav><!-- #access -->

		</div><!-- #masthead -->

	<div style="clear:both;height:1px;width:1px;"> </div>

</header><!-- #header -->
</div><!-- #header-full -->
<div id="main">
	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		<div class="breadcrumbs"><a href="https://www.retouw.nl">Home</a> &raquo;  <a href="https://www.retouw.nl/category/controlup/">ControlUp</a>  &raquo;  <span class="current">ControlUp loves Horizon Session Recording!</span></div><!--breadcrumbs-->
		<section id="container" class="three-columns-sided">
			<div id="content" role="main">
			

				<div id="post-2636" class="post-2636 post type-post status-publish format-standard has-post-thumbnail hentry category-controlup category-fling category-horizon category-vcommunity category-vexpert category-vexperteuc category-vmware tag-blast tag-controlup tag-fling tag-horizon tag-powershell tag-script-actions tag-session-recording tag-vmware">
					<h1 class="entry-title">ControlUp loves Horizon Session Recording!</h1>
										<div class="entry-meta">
						&nbsp; <span class="author vcard" >By  <a class="url fn n" rel="author" href="https://www.retouw.nl/author/admin/" title="View all posts by Wouter">Wouter</a></span> <span><time class="onDate date published" datetime="2020-11-11T07:15:07+01:00"> <a href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/" rel="bookmark">11/11/2020</a> </time></span><time class="updated"  datetime="2020-11-11T11:34:24+01:00">11/11/2020</time> <span class="bl_categ"> <a href="https://www.retouw.nl/category/controlup/" rel="tag">ControlUp</a>, <a href="https://www.retouw.nl/category/fling/" rel="tag">Fling</a>, <a href="https://www.retouw.nl/category/horizon/" rel="tag">Horizon</a>, <a href="https://www.retouw.nl/category/vcommunity/" rel="tag">vCommunity</a>, <a href="https://www.retouw.nl/category/vexpert/" rel="tag">vExpert</a>, <a href="https://www.retouw.nl/category/vexperteuc/" rel="tag">vExpertEUC</a>, <a href="https://www.retouw.nl/category/vmware/" rel="tag">VMware</a> </span>  					</div><!-- .entry-meta -->

					<div class="entry-content">
						<p>Ok maybe it&#8217;s more me than <a href="https://www.controlup.com/">ControlUp</a> but the usual audience on this blogs knows that I work for ControlUp and that I love the <a href="https://flings.vmware.com/">VMware flings</a>. Recently we received the question from several South-America based customers if we where able to start the Horizon Session Recordings using a <a href="https://support.controlup.com/hc/en-us/articles/207202955-Script-based-Actions">Script Based Action</a>. Technically we would have been able to but with the current version we would have to add the user to an ad group that was configured for this and than would be at the mercy of AD replication for the recording to actually start. Que <a href="https://twitter.com/trententtye">Trentent Tye</a> who reached out to the one and only <a href="https://andrewmorgan.ie/">Andrew Morgan</a> (imho king of the <a href="https://www.vmware.com/">VMware</a> <a href="https://www.vmware.com/products/horizon.html">Horizon</a> related flings) if it would be possible to add an API or PowerShell module to start the recordings. I guess Andrew&#8217;s reaction was that he saw the use case for this and within no-time he had a beta version ready for us that had a Powershell module. By the time you read this the new version has been added to the flings site that includes all of these goodies and you can find it <a href="https://flings.vmware.com/horizon-session-recording">here</a>.</p>
<p><span style="font-size: 8pt;">&lt;I wanted to insert a picture of Andrew here wearing a crown but that was too much&gt;</span></p>
<h3>The Horizon Session Recording fling</h3>
<p>First let&#8217;s look at what the <a href="https://flings.vmware.com/horizon-session-recording">Horizon Session Recording</a> fling actually does.</p>
<blockquote><p>VMware Horizon Session Recording allows administrators of a VMware Horizon environment to record their users activity in their Blast Extreme virtual desktop and application sessions. Recordings are uploaded from the agent devices to the central web service, for central storage and ease of viewing.</p>
<p>The Session Recordings are stored as MP4 files for watching via the web console or downloading to play in a local player.</p></blockquote>
<p>So we have an agent&gt; server application where the videos are stored on the server. During the setup I found that this was very easy but configuring a proper SSL certificate makes things a lot easier as you otherwise need to supply the thumbprint of the self-signed certificate during installation of the agent or in the registry.</p>
<p>The server interface is easy enough with the standard dashboard showing recent recordings while on the Recordings tab you can search for for specific recordings.</p>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?ssl=1" data-rel="lightbox-image-0" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2640" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0126-2/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=1918%2C716&amp;ssl=1" data-orig-size="1918,716" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0126" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=300%2C112&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=930%2C347&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2640 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=300%2C112&#038;ssl=1" alt width="300" height="112" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=300%2C112&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=1024%2C382&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=768%2C287&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=1536%2C573&amp;ssl=1 1536w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=200%2C75&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=150%2C56&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?w=1918&amp;ssl=1 1918w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?w=1860&amp;ssl=1 1860w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=300%2C112&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2640" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0126-2/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=1918%2C716&amp;ssl=1" data-orig-size="1918,716" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0126" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=300%2C112&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?fit=930%2C347&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2640" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=300%2C112&#038;ssl=1" alt="" width="300" height="112" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=300%2C112&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=1024%2C382&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=768%2C287&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=1536%2C573&amp;ssl=1 1536w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=200%2C75&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?resize=150%2C56&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?w=1918&amp;ssl=1 1918w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0126.png?w=1860&amp;ssl=1 1860w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?ssl=1" data-rel="lightbox-image-1" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2639" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0125-2/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=1915%2C571&amp;ssl=1" data-orig-size="1915,571" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0125" data-image-description data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=300%2C89&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=930%2C277&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2639 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=300%2C89&#038;ssl=1" alt width="300" height="89" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=300%2C89&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=1024%2C305&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=768%2C229&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=1536%2C458&amp;ssl=1 1536w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=200%2C60&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=150%2C45&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?w=1915&amp;ssl=1 1915w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?w=1860&amp;ssl=1 1860w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=300%2C89&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2639" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0125-2/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=1915%2C571&amp;ssl=1" data-orig-size="1915,571" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0125" data-image-description="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=300%2C89&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?fit=930%2C277&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2639" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=300%2C89&#038;ssl=1" alt="" width="300" height="89" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=300%2C89&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=1024%2C305&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=768%2C229&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=1536%2C458&amp;ssl=1 1536w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=200%2C60&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?resize=150%2C45&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?w=1915&amp;ssl=1 1915w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0125.png?w=1860&amp;ssl=1 1860w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>The agent is a plain installer that only asks for the server location and the SSL certificate thumbprint. The last one is only needed when the certificate itself is not trusted, if you used a VA signed certificate for the server there&#8217;s no need to enter the thumbprint.</p>
<p><strong>Starting a recording</strong></p>
<p>As said in the previous versions of the recorder it was required to configure an ad group and add users to that group to record their sessions. With this version we get a powershell module installed with the agent. It gets even better because if you copy the entire /api folder from the agent installation folder to another system you&#8217;re perfectly able to start recordings from there.</p>
<p>Starting a recording using powershell is a matter of importing the proper dll</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">import-module Horizon.SessionRecording.PowerShell.dll</pre>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?ssl=1" data-rel="lightbox-image-2" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2643" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0132/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=671%2C70&amp;ssl=1" data-orig-size="671,70" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0132" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=300%2C31&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=671%2C70&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2643 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=300%2C31&#038;ssl=1" alt width="300" height="31" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=300%2C31&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=200%2C21&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=150%2C16&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?w=671&amp;ssl=1 671w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=300%2C31&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2643" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0132/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=671%2C70&amp;ssl=1" data-orig-size="671,70" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0132" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=300%2C31&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?fit=671%2C70&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2643" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=300%2C31&#038;ssl=1" alt="" width="300" height="31" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=300%2C31&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=200%2C21&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?resize=150%2C16&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0132.png?w=671&amp;ssl=1 671w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>And now the user can start the recording themselves if they have too many rights by using Start-HSRSessionRecording -SessionID %sessionid%. The session ID can be found as a metric in ControlUp or in the task manager if you add the column under users.</p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?ssl=1" data-rel="lightbox-image-3" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2644" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0133/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=627%2C222&amp;ssl=1" data-orig-size="627,222" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0133" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=300%2C106&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=627%2C222&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2644 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=300%2C106&#038;ssl=1" alt width="300" height="106" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=300%2C106&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=200%2C71&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=150%2C53&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?w=627&amp;ssl=1 627w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=300%2C106&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2644" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0133/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=627%2C222&amp;ssl=1" data-orig-size="627,222" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0133" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=300%2C106&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?fit=627%2C222&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2644" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=300%2C106&#038;ssl=1" alt="" width="300" height="106" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=300%2C106&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=200%2C71&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?resize=150%2C53&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0133.png?w=627&amp;ssl=1 627w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?ssl=1" data-rel="lightbox-image-4" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2645" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0134/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=689%2C172&amp;ssl=1" data-orig-size="689,172" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0134" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=300%2C75&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=689%2C172&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2645 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=300%2C75&#038;ssl=1" alt width="300" height="75" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=300%2C75&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=200%2C50&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=150%2C37&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?w=689&amp;ssl=1 689w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=300%2C75&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2645" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0134/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=689%2C172&amp;ssl=1" data-orig-size="689,172" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0134" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=300%2C75&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?fit=689%2C172&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2645" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=300%2C75&#038;ssl=1" alt="" width="300" height="75" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=300%2C75&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=200%2C50&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?resize=150%2C37&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0134.png?w=689&amp;ssl=1 689w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Start-HSRSessionRecording -SessionID 1</pre>
<p>My user clearly didn&#8217;t have enough rights on the system so I got an error, actually not a bad thing so users can&#8217;t easily overload the server this way.</p>
<p><strong>Update</strong>: Andrew confirmed this is by design to stop users from recording each other.</p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?ssl=1" data-rel="lightbox-image-5" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2646" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0135/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=856%2C223&amp;ssl=1" data-orig-size="856,223" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0135" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=300%2C78&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=856%2C223&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2646 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=300%2C78&#038;ssl=1" alt width="300" height="78" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=300%2C78&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=768%2C200&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=200%2C52&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=150%2C39&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?w=856&amp;ssl=1 856w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=300%2C78&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2646" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0135/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=856%2C223&amp;ssl=1" data-orig-size="856,223" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0135" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=300%2C78&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?fit=856%2C223&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2646" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=300%2C78&#038;ssl=1" alt="" width="300" height="78" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=300%2C78&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=768%2C200&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=200%2C52&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?resize=150%2C39&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0135.png?w=856&amp;ssl=1 856w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>Starting the recording remote is a matter of adding the computername to the command</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Start-HSRSessionRecording -ComputerName pod02-2001 -SessionID 1</pre>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?ssl=1" data-rel="lightbox-image-6" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2647" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0137/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=1160%2C717&amp;ssl=1" data-orig-size="1160,717" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0137" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=300%2C185&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=930%2C575&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2647 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=300%2C185&#038;ssl=1" alt width="300" height="185" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=300%2C185&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=1024%2C633&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=768%2C475&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=200%2C124&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=150%2C93&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?w=1160&amp;ssl=1 1160w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=300%2C185&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2647" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0137/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=1160%2C717&amp;ssl=1" data-orig-size="1160,717" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0137" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=300%2C185&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?fit=930%2C575&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2647" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=300%2C185&#038;ssl=1" alt="" width="300" height="185" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=300%2C185&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=1024%2C633&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=768%2C475&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=200%2C124&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?resize=150%2C93&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0137.png?w=1160&amp;ssl=1 1160w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>Here you also see in the bottom right corner the message that the user receives when a recording is started.</p>
<p>And stopping is a matter of this command.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Stop-HSRSessionRecording -ComputerName pod02-2001 -SessionID 1</pre>
<p>Other Cmdlets in the PS module</p>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?ssl=1" data-rel="lightbox-image-7" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2648" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0138/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=836%2C162&amp;ssl=1" data-orig-size="836,162" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0138" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=300%2C58&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=836%2C162&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2648 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=300%2C58&#038;ssl=1" alt width="300" height="58" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=300%2C58&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=768%2C149&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=200%2C39&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=150%2C29&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?w=836&amp;ssl=1 836w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=300%2C58&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2648" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0138/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=836%2C162&amp;ssl=1" data-orig-size="836,162" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0138" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=300%2C58&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?fit=836%2C162&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2648" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=300%2C58&#038;ssl=1" alt="" width="300" height="58" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=300%2C58&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=768%2C149&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=200%2C39&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?resize=150%2C29&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0138.png?w=836&amp;ssl=1 836w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?ssl=1" data-rel="lightbox-image-8" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2649" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0139/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=841%2C341&amp;ssl=1" data-orig-size="841,341" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0139" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=300%2C122&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=841%2C341&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2649 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=300%2C122&#038;ssl=1" alt width="300" height="122" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=300%2C122&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=768%2C311&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=200%2C81&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=150%2C61&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?w=841&amp;ssl=1 841w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=300%2C122&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2649" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0139/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=841%2C341&amp;ssl=1" data-orig-size="841,341" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0139" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=300%2C122&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?fit=841%2C341&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2649" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=300%2C122&#038;ssl=1" alt="" width="300" height="122" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=300%2C122&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=768%2C311&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=200%2C81&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?resize=150%2C61&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0139.png?w=841&amp;ssl=1 841w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?ssl=1" data-rel="lightbox-image-9" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2650" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0140/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=510%2C286&amp;ssl=1" data-orig-size="510,286" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0140" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=510%2C286&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2650 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=300%2C168&#038;ssl=1" alt width="300" height="168" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=200%2C112&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?w=510&amp;ssl=1 510w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=300%2C168&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2650" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0140/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=510%2C286&amp;ssl=1" data-orig-size="510,286" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0140" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?fit=510%2C286&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2650" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=300%2C168&#038;ssl=1" alt="" width="300" height="168" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=200%2C112&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0140.png?w=510&amp;ssl=1 510w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?ssl=1" data-rel="lightbox-image-10" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2651" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0141/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=532%2C166&amp;ssl=1" data-orig-size="532,166" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0141" data-image-description data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=300%2C94&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=532%2C166&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2651 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=300%2C94&#038;ssl=1" alt width="300" height="94" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=300%2C94&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=200%2C62&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=150%2C47&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?w=532&amp;ssl=1 532w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=300%2C94&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2651" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0141/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=532%2C166&amp;ssl=1" data-orig-size="532,166" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0141" data-image-description="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=300%2C94&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?fit=532%2C166&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2651" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=300%2C94&#038;ssl=1" alt="" width="300" height="94" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=300%2C94&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=200%2C62&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?resize=150%2C47&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0141.png?w=532&amp;ssl=1 532w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<h3>Integrating with ControlUp</h3>
<p>To integrate the Horizon session recording with ControlUp I have created two basic Script Actions. both use three arguments, besides the required SessionId I add the username and machine name in the output so it&#8217;s obvious for whom the recording was started.</p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?ssl=1" data-rel="lightbox-image-11" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2653" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0142/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=677%2C315&amp;ssl=1" data-orig-size="677,315" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0142" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=300%2C140&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=677%2C315&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2653 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=300%2C140&#038;ssl=1" alt width="300" height="140" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=300%2C140&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=200%2C93&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=150%2C70&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?w=677&amp;ssl=1 677w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=300%2C140&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2653" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0142/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=677%2C315&amp;ssl=1" data-orig-size="677,315" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0142" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=300%2C140&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?fit=677%2C315&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2653" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=300%2C140&#038;ssl=1" alt="" width="300" height="140" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=300%2C140&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=200%2C93&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?resize=150%2C70&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0142.png?w=677&amp;ssl=1 677w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<pre class="EnlighterJSRAW" data-enlighter-language="powershell">$sessionId=$args[0]
$username=$args[1]
$computer=$args[2]

try{
    $InstallDir = Get-ItemPropertyValue -path "hklm:\SOFTWARE\VMware, Inc.\VMware Blast\SessionRecordingAgent" -Name installdir
}
catch{
    write-host "Error determining the Horizon Session recording installation location. Please make sure the Horizon Sesison recording Agent is Installed."
}
try{
    import-module "$($InstallDir)\api\horizon.sessionrecording.powershell.dll"
}
catch{
    write-host "Error loading the Horizon Session Recording PowerShell Module. Make sure the latest vesrion of the Horizon Session Recording Agent is installed"
}
try{
    Start-HSRSessionRecording -SessionID $sessionId
}
Catch{
    write-host "Error starting the recording"
}

write-host "Started session recording for $username on $computer"</pre>
<pre class="EnlighterJSRAW" data-enlighter-language="powershell">$sessionId=$args[0]
$username=$args[1]
$computer=$args[2]

try{
    $InstallDir = Get-ItemPropertyValue -path "hklm:\SOFTWARE\VMware, Inc.\VMware Blast\SessionRecordingAgent" -Name installdir
}
catch{
    write-host "Error determining the Horizon Session recording installation location. Please make sure the Horizon Sesison recording Agent is Installed."
}
try{
    import-module "$($InstallDir)\api\horizon.sessionrecording.powershell.dll"
}
catch{
    write-host "Error loading the Horizon Session Recording PowerShell Module. Make sure the latest vesrion of the Horizon Session Recording Agent is installed"
}
try{
    stop-HSRSessionRecording -SessionID $sessionId
}
Catch{
    write-host "Error stopping the recording"
}

write-host "Stopped session recording for $username on $computer"</pre>
<p>Both these script will get better error handling and notifications in the future but you still see the old error in the background but with the notification that the recording was started.</p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?ssl=1" data-rel="lightbox-image-12" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2664" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0871/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=1075%2C92&amp;ssl=1" data-orig-size="1075,92" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0871" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=300%2C26&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=930%2C80&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2664 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=300%2C26&#038;ssl=1" alt width="300" height="26" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=300%2C26&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=1024%2C88&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=768%2C66&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=200%2C17&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=150%2C13&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?w=1075&amp;ssl=1 1075w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=300%2C26&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2664" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0871/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=1075%2C92&amp;ssl=1" data-orig-size="1075,92" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0871" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=300%2C26&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?fit=930%2C80&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2664" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=300%2C26&#038;ssl=1" alt="" width="300" height="26" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=300%2C26&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=1024%2C88&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=768%2C66&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=200%2C17&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?resize=150%2C13&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0871.png?w=1075&amp;ssl=1 1075w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?ssl=1" data-rel="lightbox-image-13" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2655" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0143/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=1159%2C842&amp;ssl=1" data-orig-size="1159,842" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0143" data-image-description data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=300%2C218&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=930%2C676&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2655 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=300%2C218&#038;ssl=1" alt width="300" height="218" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=300%2C218&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=1024%2C744&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=768%2C558&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=200%2C145&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=150%2C109&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?w=1159&amp;ssl=1 1159w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=300%2C218&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2655" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0143/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=1159%2C842&amp;ssl=1" data-orig-size="1159,842" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0143" data-image-description="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=300%2C218&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?fit=930%2C676&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2655" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=300%2C218&#038;ssl=1" alt="" width="300" height="218" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=300%2C218&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=1024%2C744&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=768%2C558&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=200%2C145&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?resize=150%2C109&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0143.png?w=1159&amp;ssl=1 1159w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?ssl=1" data-rel="lightbox-image-14" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2656" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0144/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=1881%2C345&amp;ssl=1" data-orig-size="1881,345" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0144" data-image-description data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=300%2C55&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=930%2C171&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2656 jetpack-lazy-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=300%2C55&#038;ssl=1" alt width="300" height="55" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=300%2C55&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=1024%2C188&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=768%2C141&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=1536%2C282&amp;ssl=1 1536w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=200%2C37&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=150%2C28&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?w=1881&amp;ssl=1 1881w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=300%2C55&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2656" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0144/" data-orig-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=1881%2C345&amp;ssl=1" data-orig-size="1881,345" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0144" data-image-description="" data-medium-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=300%2C55&amp;ssl=1" data-large-file="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?fit=930%2C171&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2656" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=300%2C55&#038;ssl=1" alt="" width="300" height="55" srcset="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=300%2C55&amp;ssl=1 300w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=1024%2C188&amp;ssl=1 1024w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=768%2C141&amp;ssl=1 768w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=1536%2C282&amp;ssl=1 1536w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=200%2C37&amp;ssl=1 200w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?resize=150%2C28&amp;ssl=1 150w, https://i0.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0144.png?w=1881&amp;ssl=1 1881w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>And stopping the recording</p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?ssl=1" data-rel="lightbox-image-15" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2665" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0872/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=1061%2C83&amp;ssl=1" data-orig-size="1061,83" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0872" data-image-description data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=300%2C23&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=930%2C73&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2665 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=300%2C23&#038;ssl=1" alt width="300" height="23" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=300%2C23&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=1024%2C80&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=768%2C60&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=200%2C16&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=150%2C12&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?w=1061&amp;ssl=1 1061w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=300%2C23&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2665" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0872/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=1061%2C83&amp;ssl=1" data-orig-size="1061,83" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0872" data-image-description="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=300%2C23&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?fit=930%2C73&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2665" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=300%2C23&#038;ssl=1" alt="" width="300" height="23" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=300%2C23&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=1024%2C80&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=768%2C60&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=200%2C16&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?resize=150%2C12&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0872.png?w=1061&amp;ssl=1 1061w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?ssl=1" data-rel="lightbox-image-16" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2657" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0145/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=1245%2C778&amp;ssl=1" data-orig-size="1245,778" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0145" data-image-description data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=300%2C187&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=930%2C581&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2657 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=300%2C187&#038;ssl=1" alt width="300" height="187" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=300%2C187&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=1024%2C640&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=768%2C480&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=200%2C125&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=150%2C94&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?w=1245&amp;ssl=1 1245w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=300%2C187&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2657" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0145/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=1245%2C778&amp;ssl=1" data-orig-size="1245,778" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0145" data-image-description="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=300%2C187&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?fit=930%2C581&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2657" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=300%2C187&#038;ssl=1" alt="" width="300" height="187" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=300%2C187&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=1024%2C640&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=768%2C480&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=200%2C125&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?resize=150%2C94&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0145.png?w=1245&amp;ssl=1 1245w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?ssl=1" data-rel="lightbox-image-17" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="2658" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0146/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=1803%2C332&amp;ssl=1" data-orig-size="1803,332" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0146" data-image-description data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=300%2C55&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=930%2C172&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2658 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=300%2C55&#038;ssl=1" alt width="300" height="55" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=300%2C55&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=1024%2C189&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=768%2C141&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=1536%2C283&amp;ssl=1 1536w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=200%2C37&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=150%2C28&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?w=1803&amp;ssl=1 1803w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=300%2C55&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="2658" data-permalink="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/snag-0146/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=1803%2C332&amp;ssl=1" data-orig-size="1803,332" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0146" data-image-description="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=300%2C55&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?fit=930%2C172&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-2658" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=300%2C55&#038;ssl=1" alt="" width="300" height="55" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=300%2C55&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=1024%2C189&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=768%2C141&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=1536%2C283&amp;ssl=1 1536w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=200%2C37&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?resize=150%2C28&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/11/SNAG-0146.png?w=1803&amp;ssl=1 1803w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>And that shows how easy it is to control the Horizon Session Recording using a Script Based Action. If you combine this with a trigger, cpu usage for example you might be able to capture what is causing that spike, just remember to also create a trigger than stops it after the cpu goes down again.</p>
<p><strong>Changelog</strong></p>
<p><strong>Version 2.2.0</strong></p>
<p>Server Changes:</p>
<ul>
<li>Added the ability to import server settings easily from another running server.</li>
<li>Added the ability to filter searches based on farm / pool.</li>
<li>Added the ability to lock and unlock sessions from the session view page.</li>
</ul>
<p>Agent Changes:</p>
<p>1: Misc bugfixes.<br />
2: PowerShell API to interact with the Recording agent, to perform such tasks as:</p>
<ul>
<li>Start a session recording.</li>
<li>Stop a session recording.</li>
<li>Troubleshoot connectivity issues.</li>
<li>View machine configuration</li>
<li>Add a trusted certificate.</li>
</ul>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-2636" class="share-facebook sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-2636" class="share-linkedin sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-2636" class="share-twitter sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-2636" class="share-pinterest sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-2636" class="share-skype sd-button share-icon" href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>											</div><!-- .entry-content -->


					<div class="entry-utility">
						<div class="footer-tags"><span class="bl_posted">Tagged</span>&nbsp; <a href="https://www.retouw.nl/tag/blast/" rel="tag">Blast</a>, <a href="https://www.retouw.nl/tag/controlup/" rel="tag">ControlUP</a>, <a href="https://www.retouw.nl/tag/fling/" rel="tag">Fling</a>, <a href="https://www.retouw.nl/tag/horizon/" rel="tag">horizon</a>, <a href="https://www.retouw.nl/tag/powershell/" rel="tag">powershell</a>, <a href="https://www.retouw.nl/tag/script-actions/" rel="tag">Script Actions</a>, <a href="https://www.retouw.nl/tag/session-recording/" rel="tag">Session Recording</a>, <a href="https://www.retouw.nl/tag/vmware/" rel="tag">VMware</a>.</div><span class="bl_bookmark"> Bookmark the  <a href="https://www.retouw.nl/2020/11/11/controlup-loves-horizon-session-recording/" title="Permalink to ControlUp loves Horizon Session Recording!" rel="bookmark"> permalink</a>.</span>											</div><!-- .entry-utility -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="https://www.retouw.nl/2020/11/01/the-vmware-labs-flings-monthly-for-october-2020/" rel="prev"><span class="meta-nav">&laquo;</span> The VMware Labs flings monthly for October 2020</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-below -->

				<div id="comments" class="">
			<h3 id="comments-title">
				One Comment			</h3>
	<ol class="commentlist">
			<li class="post pingback">
		<p>Pingback: <a href='https://server.vpnwp.com/vmware/controlup-loves-horizon-session-recording/' rel='external nofollow ugc' class='url'>ControlUp loves Horizon Session Recording!</a></p>
	</li><!-- #comment-## -->
	</ol>
	 
	<p class="nocomments">Comments are closed</p> 
</div><!-- #comments -->


					<ul class="yoyo">
			<li id="eu_cookie_law_widget-2" class="widget-container widget_eu_cookie_law_widget">
<div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://automattic.com/cookies/" rel="nofollow">
		Cookie Policy	</a>
</div>
</li>		</ul>
				</div><!-- #content -->
			<div id="primary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="search-2" class="widget-container widget_search"><h3 class="widget-title">Search</h3>
<form role="search" method="get" class="searchform" action="https://www.retouw.nl/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="SEARCH" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span></button>
</form>
</li><li id="linkcat-113" class="widget-container widget_links"><h3 class="widget-title">Hands On Labs</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.vmware.com/go/try-automate-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware Automation Hands On Labs">VMware Automation Hands On Labs</a></li>
<li><a href="https://www.vmware.com/go/try-horizon-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware Horizon Hands On Labs">VMware Horizon Hands On Labs</a></li>
<li><a href="https://www.vmware.com/go/try-virtualization-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="Virtualization 101 Hands On Lab">Virtualization 101 Hands On Lab</a></li>
<li><a href="https://www.vmware.com/go/try-vsan-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware VSAN Hands On Labs">VMware VSAN Hands On Labs</a></li>

	</ul>
</li>
<li id="linkcat-114" class="widget-container widget_links"><h3 class="widget-title">Nutanix</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://next.nutanix.com/" title="Nutanix Community">Nutanix Community</a></li>
<li><a href="https://www.nutanix.com/test-drive-hyperconverged-infrastructure/" title="Try a hosted version of the Nutanix Community Edition">Nutanix Test Drive</a></li>

	</ul>
</li>
			</ul>

			
		</div>

		<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="responsive_lightbox_image_widget-8" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/04/5stars.png?fit=1061%2C717&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/04/5stars.png?fit=1061%2C717&ssl=1" width="100%" height="auto" title="5stars" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-7" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2019/08/Xb8SSDzN.png?fit=640%2C360&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2019/08/Xb8SSDzN.png?fit=640%2C360&ssl=1" width="100%" height="auto" title="Xb8SSDzN" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-9" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/04/vexperteuc.png?fit=327%2C215&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/04/vexperteuc.png?fit=327%2C215&ssl=1" width="100%" height="auto" title="vexperteuc" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-6" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/01/ntc_2020-1.jpg?fit=490%2C333&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/01/ntc_2020-1.jpg?fit=490%2C333&ssl=1" width="100%" height="auto" title="ntc_2020" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="twitter_timeline-8" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Twitter</h3><a class="twitter-timeline" data-theme="light" data-border-color="#e8e8e8" data-tweet-limit="1" data-lang="EN" data-partner="jetpack" href="https://twitter.com/Magneet_NL" href="https://twitter.com/Magneet_NL">My Tweets</a></li><li id="categories-3" class="widget-container widget_categories"><h3 class="widget-title">Categories</h3><form action="https://www.retouw.nl" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="70">.Next</option>
	<option class="level-0" value="79">Api</option>
	<option class="level-0" value="47">Backup</option>
	<option class="level-0" value="164">Blogtober</option>
	<option class="level-0" value="119">Blogtober2018</option>
	<option class="level-0" value="103">Certification</option>
	<option class="level-0" value="20">checks</option>
	<option class="level-0" value="161">CodeCon</option>
	<option class="level-0" value="176">ControlUp</option>
	<option class="level-0" value="15">ESXI</option>
	<option class="level-0" value="99">EUC Champion</option>
	<option class="level-0" value="8">Exams</option>
	<option class="level-0" value="53">Fling</option>
	<option class="level-0" value="123">Fortigate</option>
	<option class="level-0" value="63">Hackathon</option>
	<option class="level-0" value="60">Hackaton</option>
	<option class="level-0" value="40">Horizon</option>
	<option class="level-0" value="16">NSX</option>
	<option class="level-0" value="140">nug</option>
	<option class="level-0" value="31">Nutanix</option>
	<option class="level-0" value="162">Nutanix CE</option>
	<option class="level-0" value="122">Nutanix User Group</option>
	<option class="level-0" value="67">NutanixNTC</option>
	<option class="level-0" value="163">Packer</option>
	<option class="level-0" value="24">PowerCLI</option>
	<option class="level-0" value="32">Prism</option>
	<option class="level-0" value="160">REST</option>
	<option class="level-0" value="149">Runecast</option>
	<option class="level-0" value="17">Security</option>
	<option class="level-0" value="55">sponsor</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="112">vCommunity</option>
	<option class="level-0" value="77">Vembu</option>
	<option class="level-0" value="27">vExpert</option>
	<option class="level-0" value="157">vExpertEUC</option>
	<option class="level-0" value="88">VMUG</option>
	<option class="level-0" value="84">VMware</option>
	<option class="level-0" value="18">vmworld</option>
	<option class="level-0" value="21">vSphere</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->
	</div><!-- #main -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
			<div id="footer2-inner">
				<div id="site-copyright">@Wouter Kursten 2016 - Forever</div>	<div style="text-align:center;padding:5px 0 2px;text-transform:uppercase;font-size:12px;margin:1em auto 0;">
	Powered by <a target="_blank" href="http://www.cryoutcreations.eu" title="Parabola Theme by Cryout Creations">Parabola</a> &amp; <a target="_blank" href="http://wordpress.org/"
			title="Semantic Personal Publishing Platform">  WordPress.		</a>
	</div><!-- #site-info -->
	<div class="socials" id="sfooter">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div>			</div>
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

</div><!-- #wrapper -->


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.retouw.nl\/2020\/11\/11\/controlup-loves-horizon-session-recording\/":2636};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2020/11/11/controlup-loves-horizon-session-recording/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.retouw.nl/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='parabola-mobile-css'  href='https://www.retouw.nl/wp-content/themes/parabola/styles/style-mobile.css?ver=2.3.2.2' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='scroll-to-anchor-js-extra'>
/* <![CDATA[ */
var sta_settings = {"distance":"50","speed":"500","exceptions":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/scroll-to-anchor/includes/../js/scroll-to-anchor.min.js?ver=5.5.3' id='scroll-to-anchor-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.1/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.1/_inc/build/twitter-timeline.min.js' id='jetpack-twitter-timeline-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/enlighter/cache/enlighterjs.min.js?ver=phFDMi0UVifQrxR' id='enlighterjs-js'></script>
<script type='text/javascript' id='enlighterjs-js-after'>
!function(e,n){if("undefined"!=typeof EnlighterJS){var o={"selectors":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"options":{"indent":2,"ampersandCleanup":true,"linehover":true,"rawcodeDbclick":false,"textOverflow":"break","linenumbers":true,"theme":"classic","language":"generic","retainCssClasses":false,"collapse":false,"toolbarOuter":"","toolbarTop":"{BTN_RAW}{BTN_COPY}{BTN_WINDOW}{BTN_WEBSITE}","toolbarBottom":""}};(e.EnlighterJSINIT=function(){EnlighterJS.init(o.selectors.block,o.selectors.inline,o.options)})()}else{(n&&(n.error||n.log)||function(){})("Error: EnlighterJS resources not loaded yet!")}}(window,console);
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.retouw.nl\/wp-admin\/admin-ajax.php","nonce":"8c9a635523","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/www.retouw.nl\/wp-login.php?redirect_to=https%3A%2F%2Fwww.retouw.nl%2F2020%2F11%2F11%2Fcontrolup-loves-horizon-session-recording%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.1/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202046.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.1',blog:'111618698',post:'2636',tz:'1',srv:'www.retouw.nl'} ]);
	_stq.push([ 'clickTrackerInit', '111618698', '2636' ]);
</script>

</body>
</html>
