<!DOCTYPE html>
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.retouw.nl/xmlrpc.php" />
<title>[HorizonAPI]Powershell Script to push a new Desktop image using the REST api. &#8211; Retouw.nl</title>
<style type="text/css">/* Parabola Custom CSS */</style><meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Retouw.nl &raquo; Feed" href="https://www.retouw.nl/feed/" />
<link rel="alternate" type="application/rss+xml" title="Retouw.nl &raquo; Comments Feed" href="https://www.retouw.nl/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.retouw.nl\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.8.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-lightbox-prettyphoto-css'  href='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/prettyphoto/prettyPhoto.min.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='parabola-fonts-css'  href='https://www.retouw.nl/wp-content/themes/parabola/fonts/fontfaces.css?ver=2.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='parabola-style-css'  href='https://www.retouw.nl/wp-content/themes/parabola/style.css?ver=2.4.0.1' type='text/css' media='all' />
<style id='parabola-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='parabola-mobile-css'  href='https://www.retouw.nl/wp-content/themes/parabola/styles/style-mobile.css?ver=2.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='enlighterjs-css'  href='https://www.retouw.nl/wp-content/plugins/enlighter/cache/enlighterjs.min.css?ver=NWv+HezEqq2ryEL' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/10.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/prettyphoto/jquery.prettyPhoto.min.js?ver=2.3.3' id='responsive-lightbox-prettyphoto-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.8.1' id='responsive-lightbox-infinite-scroll-js'></script>
<script type='text/javascript' id='responsive-lightbox-js-extra'>
/* <![CDATA[ */
var rlArgs = {"script":"prettyphoto","selector":"lightbox","customEvents":"","activeGalleries":"1","animationSpeed":"normal","slideshow":"0","slideshowDelay":"5000","slideshowAutoplay":"0","opacity":"0.75","showTitle":"1","allowResize":"1","allowExpand":"1","width":"1080","height":"720","separator":"\/","theme":"pp_default","horizontalPadding":"20","hideFlash":"0","wmode":"opaque","videoAutoplay":"0","modal":"0","deeplinking":"0","overlayGallery":"1","keyboardShortcuts":"1","social":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.retouw.nl\/wp-admin\/admin-ajax.php","nonce":"6943b405bb"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.3.3' id='responsive-lightbox-js'></script>
<script type='text/javascript' id='parabola-frontend-js-extra'>
/* <![CDATA[ */
var parabola_settings = {"masonry":"0","magazine":"0","mobile":"1","fitvids":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/themes/parabola/js/frontend.js?ver=2.4.0.1' id='parabola-frontend-js'></script>
<link rel="https://api.w.org/" href="https://www.retouw.nl/wp-json/" /><link rel="alternate" type="application/json" href="https://www.retouw.nl/wp-json/wp/v2/posts/3123" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.retouw.nl/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.retouw.nl/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel="canonical" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/" />
<link rel='shortlink' href='https://wp.me/p7yl7A-On' />
<link rel="alternate" type="application/json+oembed" href="https://www.retouw.nl/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.retouw.nl%2F2021%2F11%2F04%2Fhorizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.retouw.nl/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.retouw.nl%2F2021%2F11%2F04%2Fhorizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api%2F&#038;format=xml" />
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="[HorizonAPI]Powershell Script to push a new Desktop image using the REST api." />
<meta property="og:url" content="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/" />
<meta property="og:description" content="I already blogged about pushing a new image using the Python module for Horizon but I decided it was time to also have a reusable script that is able to push a new image using powershell and the re…" />
<meta property="article:published_time" content="2021-11-04T19:20:02+00:00" />
<meta property="article:modified_time" content="2021-11-04T19:20:02+00:00" />
<meta property="og:site_name" content="Retouw.nl" />
<meta property="og:image" content="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/08/h8_api_logo.png?fit=256%2C256&#038;ssl=1" />
<meta property="og:image:width" content="256" />
<meta property="og:image:height" content="256" />
<meta name="twitter:creator" content="@Magneet_nl" />
<meta name="twitter:site" content="@Magneet_NL" />
<meta name="twitter:text:title" content="[HorizonAPI]Powershell Script to push a new Desktop image using the REST api." />
<meta name="twitter:image" content="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2020/08/h8_api_logo.png?fit=256%2C256&#038;ssl=1&#038;w=144" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<!--[if lt IE 9]>
<script>
document.createElement('header');
document.createElement('nav');
document.createElement('section');
document.createElement('article');
document.createElement('aside');
document.createElement('footer');
</script>
<![endif]-->
<style id="kirki-inline-styles"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-3123 single-format-standard parabola-image-four caption-light meta-light parabola_triagles parabola-menu-left">

<div id="toTop"> </div>
<div id="wrapper" class="hfeed">

<div class="socials" id="srights">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div>
<div id="header-full">

<header id="header">


		<div id="masthead">

			<div id="branding" role="banner" >

				<div id="header-container">
<div><div id="site-title"><span> <a href="https://www.retouw.nl/" title="Retouw.nl" rel="home">Retouw.nl</a> </span></div><div id="site-description" >Speaking the virtual language</div></div><div class="socials" id="sheader">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div></div>								<div style="clear:both;"></div>

			</div><!-- #branding -->
			<a id="nav-toggle"><span>&nbsp;</span></a>
			
			<nav id="access" class="jssafe" role="navigation">

					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11"><a href="https://www.retouw.nl"><span>Home</span></a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-13"><a href="https://www.retouw.nl/about/"><span>About</span></a>
<ul class="sub-menu">
	<li id="menu-item-1083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1083"><a href="https://www.retouw.nl/public-speaking/"><span>Public speaking</span></a></li>
</ul>
</li>
<li id="menu-item-1813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1813"><a href="https://www.retouw.nl/horizon-api-basics/"><span>Horizon API Basics</span></a>
<ul class="sub-menu">
	<li id="menu-item-1816" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1816"><a href="https://www.retouw.nl/2018/10/08/horizon-view-apis-back-to-basics-part-1-connecting/"><span>Horizon View Api’s: back to basics part 1: Connecting</span></a></li>
	<li id="menu-item-1815" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1815"><a href="https://www.retouw.nl/2018/10/19/horizon-view-apis-back-to-basics-part-2-queries/"><span>Horizon View Api’s: back to basics part 2: Queries</span></a></li>
	<li id="menu-item-1814" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1814"><a href="https://www.retouw.nl/2018/11/06/horizon-view-apis-back-to-basics-part-3-methods/"><span>Horizon View Api’s: back to basics part 3: Methods</span></a></li>
	<li id="menu-item-1817" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1817"><a href="https://www.retouw.nl/2018/08/11/new-view-api-query-services-in-powercli-10-1-1-pulling-event-information-without-the-sql-password/"><span>New View API query services in PowerCLI 10.1.1: pulling event information without the sql password.</span></a></li>
</ul>
</li>
<li id="menu-item-492" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-492"><a href="https://www.retouw.nl/things-i-am-always-looking-for/"><span>Things I am always looking for</span></a>
<ul class="sub-menu">
	<li id="menu-item-493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-493"><a href="https://www.retouw.nl/things-i-am-always-looking-for/install-net-framework-3-5/"><span>Install .net Framework 3.5</span></a></li>
	<li id="menu-item-497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-497"><a href="https://www.retouw.nl/things-i-am-always-looking-for/initialize-horizon-view-powercli-api/"><span>Initialize Horizon view PowerCLI &#038; API</span></a></li>
	<li id="menu-item-500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-500"><a href="https://www.retouw.nl/things-i-am-always-looking-for/create-an-array/"><span>Create an array</span></a></li>
	<li id="menu-item-680" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-680"><a href="https://www.retouw.nl/things-i-am-always-looking-for/links/"><span>Links</span></a></li>
	<li id="menu-item-763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-763"><a href="https://www.retouw.nl/things-i-am-always-looking-for/vdi-windows-versions/"><span>VMware Horizon &#038; Windows versions</span></a></li>
</ul>
</li>
<li id="menu-item-2696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2696"><a href="https://www.retouw.nl/100-days-of-code/"><span>100 Days of Code</span></a>
<ul class="sub-menu">
	<li id="menu-item-2701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2701"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/"><span>Days 1-7</span></a>
	<ul class="sub-menu">
		<li id="menu-item-2697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2697"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/100-days-of-code-day-1/"><span>Day 1</span></a></li>
		<li id="menu-item-2705" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2705"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-2/"><span>Day 2</span></a></li>
		<li id="menu-item-2715" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2715"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-3/"><span>Day 3</span></a></li>
		<li id="menu-item-2718" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2718"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-4/"><span>Day 4</span></a></li>
		<li id="menu-item-2721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2721"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-5/"><span>Day 5</span></a></li>
		<li id="menu-item-2725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2725"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-6/"><span>Day 6</span></a></li>
		<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.retouw.nl/100-days-of-code/days-1-7/day-7/"><span>Day 7</span></a></li>
	</ul>
</li>
	<li id="menu-item-2738" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2738"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/"><span>Days 8-14</span></a>
	<ul class="sub-menu">
		<li id="menu-item-2739" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2739"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-8/"><span>Day 8</span></a></li>
		<li id="menu-item-2744" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2744"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-9/"><span>Day 9</span></a></li>
		<li id="menu-item-2750" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2750"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-10/"><span>Day 10</span></a></li>
		<li id="menu-item-2753" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2753"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-11/"><span>Day 11</span></a></li>
		<li id="menu-item-2759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2759"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-12/"><span>Day 12</span></a></li>
		<li id="menu-item-2767" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2767"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-13/"><span>Day 13</span></a></li>
		<li id="menu-item-2764" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2764"><a href="https://www.retouw.nl/100-days-of-code/days-8-14/day-14/"><span>Day 14</span></a></li>
	</ul>
</li>
	<li id="menu-item-2780" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2780"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/"><span>Days 15-21</span></a>
	<ul class="sub-menu">
		<li id="menu-item-2779" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2779"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-15/"><span>Day 15</span></a></li>
		<li id="menu-item-2778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2778"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-16/"><span>Day 16</span></a></li>
		<li id="menu-item-2783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2783"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-17/"><span>Day 17</span></a></li>
		<li id="menu-item-2789" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2789"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-18/"><span>Day 18</span></a></li>
		<li id="menu-item-2788" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2788"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-19/"><span>Day 19</span></a></li>
		<li id="menu-item-2797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2797"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-20/"><span>Day 20</span></a></li>
		<li id="menu-item-2815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2815"><a href="https://www.retouw.nl/100-days-of-code/days-15-21/day-21/"><span>Day 21</span></a></li>
	</ul>
</li>
	<li id="menu-item-2814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2814"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/"><span>Days 22-28</span></a>
	<ul class="sub-menu">
		<li id="menu-item-2813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2813"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/day-22/"><span>Day 22</span></a></li>
		<li id="menu-item-2812" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2812"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/day-23/"><span>Day 23</span></a></li>
		<li id="menu-item-2811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2811"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/day-24/"><span>Day 24</span></a></li>
		<li id="menu-item-2820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2820"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/day-25/"><span>Day 25</span></a></li>
		<li id="menu-item-2823" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2823"><a href="https://www.retouw.nl/100-days-of-code/days-22-28/day-26/"><span>Day 26</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-549"><a href="https://www.retouw.nl/certifications/"><span>Certifications</span></a></li>
</ul></div>
			</nav><!-- #access -->

		</div><!-- #masthead -->

	<div style="clear:both;height:1px;width:1px;"> </div>

</header><!-- #header -->
</div><!-- #header-full -->
<div id="main">
	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		<div class="breadcrumbs"><a href="https://www.retouw.nl">Home</a> &raquo;  <a href="https://www.retouw.nl/category/api/">Api</a>  &raquo;  <span class="current">[HorizonAPI]Powershell Script to push a new Desktop image using the REST api.</span></div><!--breadcrumbs-->
		<section id="container" class="three-columns-sided">
			<div id="content" role="main">
			

				<div id="post-3123" class="post-3123 post type-post status-publish format-standard has-post-thumbnail hentry category-api category-horizon category-powershell category-rest category-vcommunity category-vexpert category-vexperteuc tag-api tag-horizon tag-powershell tag-rest tag-vccommunity tag-vexpert">
					<h1 class="entry-title">[HorizonAPI]Powershell Script to push a new Desktop image using the REST api.</h1>
										<div class="entry-meta">
						&nbsp; <span class="author vcard" >By  <a class="url fn n" rel="author" href="https://www.retouw.nl/author/admin/" title="View all posts by Wouter">Wouter</a></span> <span><time class="onDate date published" datetime="2021-11-04T20:20:02+01:00"> <a href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/" rel="bookmark">04/11/2021</a> </time></span><time class="updated"  datetime="2021-11-04T20:20:02+01:00">04/11/2021</time> <span class="bl_categ"> <a href="https://www.retouw.nl/category/api/" rel="tag">Api</a>, <a href="https://www.retouw.nl/category/horizon/" rel="tag">Horizon</a>, <a href="https://www.retouw.nl/category/powershell/" rel="tag">Powershell</a>, <a href="https://www.retouw.nl/category/rest/" rel="tag">REST</a>, <a href="https://www.retouw.nl/category/vcommunity/" rel="tag">vCommunity</a>, <a href="https://www.retouw.nl/category/vexpert/" rel="tag">vExpert</a>, <a href="https://www.retouw.nl/category/vexperteuc/" rel="tag">vExpertEUC</a> </span>  					</div><!-- .entry-meta -->

					<div class="entry-content">
						<p>I already blogged about pushing a new image using the Python module for Horizon but I decided it was time to also have a reusable script that is able to push a new image using powershell and the rest api for Horizon. The script that I created has 10(!) arguments of which 6 are required:</p>
<ul style="list-style-type: disc;">
<li>ConnectionServerURL: https://server.domain.dom</li>
<li>vCenterURL: https://vcenter.domain.dom</li>
<li>DataCenterName: Name of the datacenter the source VM resides in</li>
<li>BaseVMName : name of the source VM</li>
<li>
<div>
<div>BaseSnapShotName: name of the source Snapshot</div>
</div>
</li>
<li>
<div>DesktopPoolName: name of the source Desktop Pool to apply the snapshot to</div>
</li>
</ul>
<p>The datacenter name is required as that&#8217;s an requirement to grab the Source VM details.</p>
<p>The optional arguments are:</p>
<ul>
<li>Credentials: PSCRedential object (get-credential for example) when not provided it will ask for user and password. The user should also contain the domain i.e. domain\user</li>
<li>StoponError: $true or $false depending on if you want to stop on errors, defaults to $true if not provided</li>
<li>logoff_policy: Optional WAIT_FOR_LOGOFF or FORCE_LOGOFF depending on the logoff policy you want</li>
<li>Scheduledtime: [DateTime] object in case you want to push for the future</li>
</ul>
<p>The script itself was fairly easy to create, from the api explorer it was easy what id&#8217;s I needed and it was a matter of working back so I had all of them. In the end the hardest part was getting the scheduling to work. I used the (standard?) 10 digit epoch that most people use but it turns out that VMware wanted to schedule it very exactly in milliseconds! For the rest I used the well known functions for authentication but not my generic function for filtering or pagination as almost none of the api calls I use in this script support that.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="powershell">&lt;#
    .SYNOPSIS
    Pushes a new Golden Image to a Desktop Pool

    .DESCRIPTION
    This script uses the Horizon rest api's to push a new golden image to a VMware Horizon Desktop Pool

    .EXAMPLE
    .\Horizon_Rest_Push_Image.ps1 -ConnectionServerURL https://pod1cbr1.loft.lab -Credentials $creds -vCenterURL "https://pod1vcr1.loft.lab" -DataCenterName "Datacenter_Loft" -baseVMName "W21h1-2021-09-08-15-48" -BaseSnapShotName "Demo Snapshot" -DesktopPoolName "Pod01-Pool02"

    .PARAMETER Credential
    Mandatory: No
    Type: PSCredential
    Object with credentials for the connection server with domain\username and password. If not supplied the script will ask for user and password.

    .PARAMETER ConnectionServerURL
    Mandatory: Yes
    Default: String
    URL of the connection server to connect to

    .PARAMETER vCenterURL
    Mandatory: Yes
    Username of the user to look for

    .PARAMETER DataCenterName
    Mandatory: Yes
    Domain to look in

    .PARAMETER BaseVMName
    Mandatory: Yes
    Domain to look in

    .PARAMETER BaseSnapShotName
    Mandatory: Yes
    Domain to look in

    .PARAMETER DesktopPoolName
    Mandatory: Yes
    Domain to look in

    .PARAMETER StoponError
    Mandatory: No
    Boolean to stop on error or not

    .PARAMETER logoff_policy
    Mandatory: No
    String FORCE_LOGOFF or WAIT_FOR_LOGOFF to set the logoff policy.

    .PARAMETER Scheduledtime
    Mandatory: No
    Time to schedule the image push in [DateTime] format.

    .NOTES
    Minimum required version: VMware Horizon 8 2012
    Created by: Wouter Kursten
    First version: 03-11-2021

    .COMPONENT
    Powershell Core
#&gt;

[CmdletBinding()]
param (
    [Parameter(Mandatory=$false,
    HelpMessage='Credential object as domain\username with password' )]
    [PSCredential] $Credentials,

    [Parameter(Mandatory=$true,  HelpMessage='FQDN of the connectionserver' )]
    [ValidateNotNullOrEmpty()]
    [string] $ConnectionServerURL,

    [parameter(Mandatory = $true,
    HelpMessage = "URL of the vCenter to look in i.e. https://vcenter.domain.lab")]
    [ValidateNotNullOrEmpty()]
    [string]$vCenterURL,

    [parameter(Mandatory = $true,
    HelpMessage = "Name of the Datacenter to look in.")]
    [ValidateNotNullOrEmpty()]
    [string]$DataCenterName,

    [parameter(Mandatory = $true,
    HelpMessage = "Name of the Golden Image VM.")]
    [ValidateNotNullOrEmpty()]
    [string]$BaseVMName,

    [parameter(Mandatory = $true,
    HelpMessage = "Name of the Snapshot to use for the Golden Image.")]
    [ValidateNotNullOrEmpty()]
    [string]$BaseSnapShotName,

    [parameter(Mandatory = $true,
    HelpMessage = "Name of the Desktop Pool.")]
    [ValidateNotNullOrEmpty()]
    [string]$DesktopPoolName,

    [parameter(Mandatory = $false,
    HelpMessage = "Name of the Desktop Pool.")]
    [ValidateNotNullOrEmpty()]
    [bool]$StoponError = $true,

    [parameter(Mandatory = $false,
    HelpMessage = "Name of the Desktop Pool.")]
    [ValidateSet('WAIT_FOR_LOGOFF','FORCE_LOGOFF', IgnoreCase = $false)]
    [string]$logoff_policy = "WAIT_FOR_LOGOFF",

    [parameter(Mandatory = $false,
    HelpMessage = "DateTime object for the moment of scheduling the image push.Defaults to immediately")]
    [datetime]$Scheduledtime
)
if($Credentials){
    $username=($credentials.username).split("\")[1]
    $domain=($credentials.username).split("\")[0]
    $password=$credentials.password
}
else{
    $credentials = Get-Credential
    $username=($credentials.username).split("\")[1]
    $domain=($credentials.username).split("\")[0]
    $password=$credentials.password
}

$BSTR = [System.Runtime.InteropServices.Marshal]::SecureStringToBSTR($password) 
$UnsecurePassword = [System.Runtime.InteropServices.Marshal]::PtrToStringAuto($BSTR)

function Get-HRHeader(){
    param($accessToken)
    return @{
        'Authorization' = 'Bearer ' + $($accessToken.access_token)
        'Content-Type' = "application/json"
    }
}
function Open-HRConnection(){
    param(
        [string] $username,
        [string] $password,
        [string] $domain,
        [string] $url
    )

    $Credentials = New-Object psobject -Property @{
        username = $username
        password = $password
        domain = $domain
    }

    return invoke-restmethod -Method Post -uri "$ConnectionServerURL/rest/login" -ContentType "application/json" -Body ($Credentials | ConvertTo-Json)
}
function Close-HRConnection(){
    param(
        $accessToken,
        $ConnectionServerURL
    )
    return Invoke-RestMethod -Method post -uri "$ConnectionServerURL/rest/logout" -ContentType "application/json" -Body ($accessToken | ConvertTo-Json)
}

try{
    $accessToken = Open-HRConnection -username $username -password $UnsecurePassword -domain $Domain -url $ConnectionServerURL
}
catch{
    throw "Error Connecting: $_"
}

$vCenters = Invoke-RestMethod -Method Get -uri "$ConnectionServerURL/rest/monitor/v2/virtual-centers" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken)
$vcenterid = ($vCenters | where-object {$_.name -like "*$vCenterURL*"}).id
$datacenters = Invoke-RestMethod -Method Get -uri "$ConnectionServerURL/rest/external/v1/datacenters?vcenter_id=$vcenterid" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken)
$datacenterid = ($datacenters | where-object {$_.name -eq $DataCenterName}).id
$basevms = Invoke-RestMethod -Method Get -uri "$ConnectionServerURL/rest/external/v1/base-vms?datacenter_id=$datacenterid&amp;filter_incompatible_vms=false&amp;vcenter_id=$vcenterid" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken)
$basevmid = ($basevms | where-object {$_.name -eq $baseVMName}).id
$basesnapshots = Invoke-RestMethod -Method Get -uri "$ConnectionServerURL/rest/external/v1/base-snapshots?base_vm_id=$basevmid&amp;vcenter_id=$vcenterid" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken)
$basesnapshotid = ($basesnapshots | where-object {$_.name -eq $BaseSnapShotName}).id
$desktoppools = Invoke-RestMethod -Method Get -uri "$ConnectionServerURL/rest/inventory/v1/desktop-pools" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken)
$desktoppoolid = ($desktoppools | where-object {$_.name -eq $DesktopPoolName}).id
$startdate = (get-date -UFormat %s)
$datahashtable = [ordered]@{}
$datahashtable.add('logoff_policy',$logoff_policy)
$datahashtable.add('parent_vm_id',$basevmid)
$datahashtable.add('snapshot_id',$basesnapshotid)
if($Scheduledtime){
    $starttime = get-date $Scheduledtime
    $epoch = ([DateTimeOffset]$starttime).ToUnixTimeMilliseconds()
    $datahashtable.add('start_time',$epoch)
}

$datahashtable.add('stop_on_first_error',$StoponError)
$json = $datahashtable | convertto-json
Invoke-RestMethod -Method Post -uri "$ConnectionServerURL/rest/inventory/v1/desktop-pools/$desktoppoolid/action/schedule-push-image" -ContentType "application/json" -Headers (Get-HRHeader -accessToken $accessToken) -body $json
</pre>
<p>I use it like this for example:</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">D:\GIT\Various_Scripts\Horizon_Rest_Push_Image.ps1 -ConnectionServerURL https://pod1cbr1.loft.lab -vCenterURL "https://pod1vcr1.loft.lab" -DataCenterName "Datacenter_Loft" -baseVMName "W21h1-2021-09-08-15-48" -BaseSnapShotName "Demo Snapshot" -DesktopPoolName "Pod01-Pool01" -logoff_policy WAIT_FOR_LOGOFF -StoponError $true -Scheduledtime ((get-date).AddMinutes(75))</pre>
<p>Except for the question for username and password (in this case) there&#8217;s no response</p>
<p><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?ssl=1" data-rel="lightbox-image-0" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="3124" data-permalink="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/snag-0183/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=1902%2C445&amp;ssl=1" data-orig-size="1902,445" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0183" data-image-description data-image-caption data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=300%2C70&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=930%2C218&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-3124 jetpack-lazy-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=300%2C70&#038;ssl=1" alt width="300" height="70" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=300%2C70&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=1024%2C240&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=768%2C180&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=1536%2C359&amp;ssl=1 1536w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=200%2C47&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=150%2C35&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?w=1902&amp;ssl=1 1902w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=300%2C70&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="3124" data-permalink="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/snag-0183/" data-orig-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=1902%2C445&amp;ssl=1" data-orig-size="1902,445" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0183" data-image-description="" data-image-caption="" data-medium-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=300%2C70&amp;ssl=1" data-large-file="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?fit=930%2C218&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-3124" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=300%2C70&#038;ssl=1" alt="" width="300" height="70" srcset="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=300%2C70&amp;ssl=1 300w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=1024%2C240&amp;ssl=1 1024w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=768%2C180&amp;ssl=1 768w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=1536%2C359&amp;ssl=1 1536w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=200%2C47&amp;ssl=1 200w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?resize=150%2C35&amp;ssl=1 150w, https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0183.png?w=1902&amp;ssl=1 1902w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>and the push image is scheduled 75 minutes in the future</p>
<p><a href="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?ssl=1" data-rel="lightbox-image-1" data-rl_title="" data-rl_caption="" title=""><img data-attachment-id="3125" data-permalink="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/snag-0184/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=1175%2C150&amp;ssl=1" data-orig-size="1175,150" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0184" data-image-description data-image-caption data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=300%2C38&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=930%2C119&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-3125 jetpack-lazy-image" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=300%2C38&#038;ssl=1" alt width="300" height="38" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=300%2C38&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=1024%2C131&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=768%2C98&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=200%2C26&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=150%2C19&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?w=1175&amp;ssl=1 1175w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=300%2C38&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="3125" data-permalink="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/snag-0184/" data-orig-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=1175%2C150&amp;ssl=1" data-orig-size="1175,150" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SNAG-0184" data-image-description="" data-image-caption="" data-medium-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=300%2C38&amp;ssl=1" data-large-file="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?fit=930%2C119&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-3125" src="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=300%2C38&#038;ssl=1" alt="" width="300" height="38" srcset="https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=300%2C38&amp;ssl=1 300w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=1024%2C131&amp;ssl=1 1024w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=768%2C98&amp;ssl=1 768w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=200%2C26&amp;ssl=1 200w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?resize=150%2C19&amp;ssl=1 150w, https://i1.wp.com/www.retouw.nl/wp-content/uploads/2021/11/SNAG-0184.png?w=1175&amp;ssl=1 1175w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></a></p>
<p>As always the script itself is also available at Github <a href="https://github.com/Magneet/Various_Scripts/blob/master/Horizon_Rest_Push_Image.ps1">HERE</a>.</p>
<p>Next time I&#8217;ll add more error handling and update the script to also push images to RDS farms 🙂</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-3123" class="share-facebook sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-3123" class="share-linkedin sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-3123" class="share-twitter sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-3123" class="share-pinterest sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-3123" class="share-skype sd-button share-icon" href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>											</div><!-- .entry-content -->


					<div class="entry-utility">
						<div class="footer-tags"><span class="bl_posted">Tagged</span>&nbsp; <a href="https://www.retouw.nl/tag/api/" rel="tag">api</a>, <a href="https://www.retouw.nl/tag/horizon/" rel="tag">horizon</a>, <a href="https://www.retouw.nl/tag/powershell/" rel="tag">powershell</a>, <a href="https://www.retouw.nl/tag/rest/" rel="tag">REST</a>, <a href="https://www.retouw.nl/tag/vccommunity/" rel="tag">vCcommunity</a>, <a href="https://www.retouw.nl/tag/vexpert/" rel="tag">vExpert</a>.</div><span class="bl_bookmark"> Bookmark the  <a href="https://www.retouw.nl/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/" title="Permalink to [HorizonAPI]Powershell Script to push a new Desktop image using the REST api." rel="bookmark"> permalink</a>.</span>											</div><!-- .entry-utility -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="https://www.retouw.nl/2021/10/02/horizon-rest-api-powershell-7-paging-and-filtering-with-samples/" rel="prev"><span class="meta-nav">&laquo;</span> Horizon REST API + Powershell 7: pagination and filtering (with samples)</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-below -->

				<div id="comments" class="hideme">
	<p class="nocomments">Comments are closed.</p>
</div><!-- #comments -->


					<ul class="yoyo">
			<li id="eu_cookie_law_widget-2" class="widget-container widget_eu_cookie_law_widget">
<div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://automattic.com/cookies/" rel="nofollow">
		Cookie Policy	</a>
</div>
</li>		</ul>
				</div><!-- #content -->
			<div id="primary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="search-2" class="widget-container widget_search"><h3 class="widget-title">Search</h3>
<form role="search" method="get" class="searchform" action="https://www.retouw.nl/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="SEARCH" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span></button>
</form>
</li><li id="linkcat-113" class="widget-container widget_links"><h3 class="widget-title">Hands On Labs</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.vmware.com/go/try-vsan-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware VSAN Hands On Labs">VMware VSAN Hands On Labs</a></li>
<li><a href="https://www.vmware.com/go/try-virtualization-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="Virtualization 101 Hands On Lab">Virtualization 101 Hands On Lab</a></li>
<li><a href="https://www.vmware.com/go/try-horizon-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware Horizon Hands On Labs">VMware Horizon Hands On Labs</a></li>
<li><a href="http://vmware.com/go/try-vsphere-hol?src=af_5b83426144d8c&#038;cid=70134000001YXMZ" title="VMware vSphere Hands On Labs">VMware vSphere Hands On Labs</a></li>

	</ul>
</li>
<li id="linkcat-114" class="widget-container widget_links"><h3 class="widget-title">Nutanix</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.nutanix.com/test-drive-hyperconverged-infrastructure/" title="Try a hosted version of the Nutanix Community Edition">Nutanix Test Drive</a></li>
<li><a href="https://next.nutanix.com/" title="Nutanix Community">Nutanix Community</a></li>

	</ul>
</li>
			</ul>

			
		</div>

		<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="responsive_lightbox_image_widget-10" class="widget-container rl-image-widget"><h3 class="widget-title">Image</h3><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/02/6stars.png?fit=1061%2C717&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/02/6stars.png?fit=1061%2C717&ssl=1" width="100%" height="auto" title="6stars" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-6" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2021/02/ntc_650x650.png?fit=340%2C340&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i0.wp.com/www.retouw.nl/wp-content/uploads/2021/02/ntc_650x650.png?fit=340%2C340&ssl=1" width="100%" height="auto" title="ntc_650x650" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-7" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/02/ezgif-3-d8b1c1078596.png?fit=301%2C308&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2021/02/ezgif-3-d8b1c1078596.png?fit=301%2C308&ssl=1" width="100%" height="auto" title="ezgif-3-d8b1c1078596" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="responsive_lightbox_image_widget-9" class="widget-container rl-image-widget"><h3 class="widget-title"></h3><a href="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/04/vexperteuc.png?fit=327%2C215&ssl=1" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://i2.wp.com/www.retouw.nl/wp-content/uploads/2020/04/vexperteuc.png?fit=327%2C215&ssl=1" width="100%" height="auto" title="vexperteuc" alt="" /></a><div class="rl-image-widget-text"></div></li><li id="twitter_timeline-8" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Twitter</h3><a class="twitter-timeline" data-theme="light" data-border-color="#e8e8e8" data-tweet-limit="1" data-lang="EN" data-partner="jetpack" href="https://twitter.com/Magneet_NL" href="https://twitter.com/Magneet_NL">My Tweets</a></li><li id="categories-3" class="widget-container widget_categories"><h3 class="widget-title">Categories</h3><form action="https://www.retouw.nl" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="70">.Next</option>
	<option class="level-0" value="182">100daysofcode</option>
	<option class="level-0" value="79">Api</option>
	<option class="level-0" value="47">Backup</option>
	<option class="level-0" value="164">Blogtober</option>
	<option class="level-0" value="119">Blogtober2018</option>
	<option class="level-0" value="103">Certification</option>
	<option class="level-0" value="20">checks</option>
	<option class="level-0" value="161">CodeCon</option>
	<option class="level-0" value="176">ControlUp</option>
	<option class="level-0" value="15">ESXI</option>
	<option class="level-0" value="99">EUC Champion</option>
	<option class="level-0" value="8">Exams</option>
	<option class="level-0" value="53">Fling</option>
	<option class="level-0" value="123">Fortigate</option>
	<option class="level-0" value="63">Hackathon</option>
	<option class="level-0" value="60">Hackaton</option>
	<option class="level-0" value="40">Horizon</option>
	<option class="level-0" value="16">NSX</option>
	<option class="level-0" value="140">nug</option>
	<option class="level-0" value="31">Nutanix</option>
	<option class="level-0" value="162">Nutanix CE</option>
	<option class="level-0" value="122">Nutanix User Group</option>
	<option class="level-0" value="67">NutanixNTC</option>
	<option class="level-0" value="163">Packer</option>
	<option class="level-0" value="24">PowerCLI</option>
	<option class="level-0" value="200">Powershell</option>
	<option class="level-0" value="32">Prism</option>
	<option class="level-0" value="183">Python</option>
	<option class="level-0" value="160">REST</option>
	<option class="level-0" value="149">Runecast</option>
	<option class="level-0" value="17">Security</option>
	<option class="level-0" value="55">sponsor</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="112">vCommunity</option>
	<option class="level-0" value="77">Vembu</option>
	<option class="level-0" value="27">vExpert</option>
	<option class="level-0" value="157">vExpertEUC</option>
	<option class="level-0" value="88">VMUG</option>
	<option class="level-0" value="84">VMware</option>
	<option class="level-0" value="18">vmworld</option>
	<option class="level-0" value="21">vSphere</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->
	</div><!-- #main -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
			<div id="footer2-inner">
				<div id="site-copyright">@Wouter Kursten 2016 - Forever</div>	<div style="text-align:center;padding:5px 0 2px;text-transform:uppercase;font-size:12px;margin:1em auto 0;">
	Powered by <a target="_blank" href="http://www.cryoutcreations.eu" title="Parabola Theme by Cryout Creations">Parabola</a> &amp; <a target="_blank" href="http://wordpress.org/"
			title="Semantic Personal Publishing Platform">  WordPress.		</a>
	</div><!-- #site-info -->
	<div class="socials" id="sfooter">
			<a  target="_blank"  rel="nofollow" href="https://twitter.com/magneet_nl"
			class="socialicons social-Twitter" title="Twitter">
				<img alt="Twitter" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.linkedin.com/in/wouter-kursten-47857510/"
			class="socialicons social-LinkedIn" title="LinkedIn">
				<img alt="LinkedIn" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/LinkedIn.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://github.com/Magneet"
			class="socialicons social-Github" title="Github">
				<img alt="Github" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/Github.png" />
			</a>
			<a  target="_blank"  rel="nofollow" href="https://www.retouw.nl/feed/"
			class="socialicons social-RSS" title="RSS">
				<img alt="RSS" src="https://www.retouw.nl/wp-content/themes/parabola/images/socials/RSS.png" />
			</a></div>			</div>
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

</div><!-- #wrapper -->

		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<div id="jp-carousel-comment-form-commenting-as">
												<p id="jp-carousel-commenting-as">
													You must be <a href="#" class="jp-carousel-comment-login">logged in</a> to post a comment.												</p>
											</div>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.retouw.nl\/2021\/11\/04\/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api\/":3123};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2021/11/04/horizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.retouw.nl/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='scroll-to-anchor-js-extra'>
/* <![CDATA[ */
var sta_settings = {"distance":"50","speed":"500","exceptions":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/scroll-to-anchor/includes/../js/scroll-to-anchor.min.js?ver=5.8.1' id='scroll-to-anchor-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/twitter-timeline.min.js' id='jetpack-twitter-timeline-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/intersection-observer.js?ver=1.1.3' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/lazy-images.js?ver=1.1.3' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.retouw.nl/wp-content/plugins/enlighter/cache/enlighterjs.min.js?ver=NWv+HezEqq2ryEL' id='enlighterjs-js'></script>
<script type='text/javascript' id='enlighterjs-js-after'>
!function(e,n){if("undefined"!=typeof EnlighterJS){var o={"selectors":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"options":{"indent":2,"ampersandCleanup":true,"linehover":true,"rawcodeDbclick":false,"textOverflow":"break","linenumbers":true,"theme":"classic","language":"generic","retainCssClasses":false,"collapse":false,"toolbarOuter":"","toolbarTop":"{BTN_RAW}{BTN_COPY}{BTN_WINDOW}{BTN_WEBSITE}","toolbarBottom":""}};(e.EnlighterJSINIT=function(){EnlighterJS.init(o.selectors.block,o.selectors.inline,o.options)})()}else{(n&&(n.error||n.log)||function(){})("Error: EnlighterJS resources not loaded yet!")}}(window,console);
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/www.retouw.nl\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.retouw.nl\/wp-admin\/admin-ajax.php","nonce":"4ab2ac6bf3","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/www.retouw.nl\/wp-login.php?redirect_to=https%3A%2F%2Fwww.retouw.nl%2F2021%2F11%2F04%2Fhorizonapipowershell-script-to-push-a-new-desktop-image-using-the-rest-api%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>
<script type="text/javascript">var cryout_global_content_width = 930;</script><script src='https://stats.wp.com/e-202144.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'111618698',post:'3123',tz:'1',srv:'www.retouw.nl'} ]);
	_stq.push([ 'clickTrackerInit', '111618698', '3123' ]);
</script>

</body>
</html>
